
 

 

 

PhotoLynx® ProServices© 

User’s Manual 
 
ProServices© produces service items such as ID cards, memory mates, proof sheets, pictorial directories, 

and many other items. ProServices© allows you the flexibility to create and modify any service item. 

 

 

 

 

PhotoLynx® Mission Statement 
PhotoLynx®, Inc. strives to keep abreast of the latest hardware and software technology while continuing 

to support existing standards. PhotoLynx® places the highest value on supporting and serving our clients. 

PhotoLynx® seeks to align itself with businesses providing hardware, software and services that will 

benefit our clients in the photographic industry.  



 

 

  PhotoLynx® ProServices©    1 

Table of Contents 
PHOTOLYNX

®
 MISSION STATEMENT ......................................................................................................... 0 

GETTING STARTED ................................................................................................................................ 2 

SYSTEM REQUIREMENTS .................................................................................................................... 2 

INSTRUCTIONS FOR INSTALLING/ACTIVATING PROSERVICES
©

 SOFTWARE ....................................................... 3 

TO INSTALL: ..................................................................................................................................... 3 

TO ACTIVATE: .................................................................................................................................. 3 

HOW TO SUBMIT SERIALIZATION FILES: ............................................................................................ 3 

HOW TO LOAD AN ACTIVATION FILE: ............................................................................................... 3 

OVERVIEW .......................................................................................................................................... 4 

THE FILE MENU: SERVICE SETUP ............................................................................................................. 5 

PAGE TAB ........................................................................................................................................... 6 

MARGINS TAB ...................................................................................................................................... 7 

HEADER/FOOTER TAB ........................................................................................................................... 8 

SHEET TAB .......................................................................................................................................... 9 

SORT OPTIONS ............................................................................................................................... 10 

PROCESS TAB ..................................................................................................................................... 11 

SERVICE SETUP FILE MENU .................................................................................................................. 11 

CREATING SERVICES: THE BASIC STEPS ................................................................................................... 12 

THE TEMPLATE BUILDER ...................................................................................................................... 12 

TEMPLATE BUILDER: OBJECTS ........................................................................................................... 13 

TEMPLATE BUILDER: TOOLS .............................................................................................................. 14 

RESET TEMPLATE SIZE ......................................................................................................................... 15 

THE PRINT MENU: .............................................................................................................................. 15 

PRINT PREVIEW .............................................................................................................................. 15 

ENABLE CODABAR CHECK DIGIT ........................................................................................................ 16 

PRINT ........................................................................................................................................... 16 

THE HELP MENU ................................................................................................................................ 17 

ACTIVATION ................................................................................................................................... 17 

ABOUT PROSERVICES
© .................................................................................................................... 17 

GREEN SCREEN PROOFS ....................................................................................................................... 18 

HOW TO CREATE 3 DIMENSIONAL PROOFS ............................................................................................. 19 

MULTI-POSE PROOF SHEETS ................................................................................................................ 20 

IMAGEMATCH
©

 SETUP .................................................................................................................... 20 

CREATING YOUR SERVICE ................................................................................................................. 20 

ADD THE PROOF PACKAGE TO STUDENTS ............................................................................................ 21 

PRINTING PROOF SHEETS ................................................................................................................. 21 

ADDING YOUR IMAGE NAME TO YOUR MULTI-POSE PROOF SHEET ............................................................. 22 

DYNAMICALLY CHANGE GRAPHICS ......................................................................................................... 22 

 



 

 

  PhotoLynx® ProServices©    2 

Getting Started  

Before installation, your computer must meet the following requirements: 

System Requirements 
Minimum: 

 Intel Celeron or AMD Duron processor @ 1.5 GHz 

 Microsoft Windows 7 

 1GB of RAM (for Green Screen V.2, a MIN of 2GB is needed) 

 4 GB of available hard-disk space 

 Color monitor with 8 million (16-bit) or greater video card 

 Monitor resolution of 1024×768 or greater 
 

Recommended: 

 Intel Pentium 4 or AMD Athlon XP processor @ 3.0 + GHz; Duo or Quad core for faster rendering 

 Microsoft Windows 7, Windows 8 

 32 or 64 bit 

 4-8 GB recommended for GS V.2 

 160 GB of available hard-disk space 

 Color monitor with 16 million (32-bit) or greater video card w/64 MB of RAM 

 Monitor resolution of 1024×768 or greater 

 CD-R / CD-RW, DVD-R drive 

 Fast Connection to the Internet (including e-mail) 
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Instructions for Installing/Activating ProServices© Software 

 You should have received an email from either the PhotoLynx® Technical Support office or your lab with 

the base install of ProServices©, as well as 2 upgrade links.  

To Install: 

1. Download all three downloaders that were emailed to you 

2. Run each installer in order they were sent to you, making sure to right click on the installer and 

choose Run as Administrator 

3. Follow the install prompts 

4. Once finished installing all three links, right-click on your ProServices© icon on your desktop 

5. Select Properties 

6. Under your Compatibility tab, check off Run this 

program as an administrator 

7. Click Apply then OK  

To Activate: 

ProServices© will be activated along with your ImageMatch© 

software. To activate your ImageMatch© software, we first 

need to receive a serialization file from you. Once received, we 

will email back an activation file to load into the software. To do 

this: 

How to Submit Serialization Files:  

1. Run ImageMatch©  
2. If an Activation menu doesn’t automatically pop up, go to the Help>About menu and click on the 

Activation button 
3. Completely fill out the customer information  
4. Select:  File menu>Create Serialization File 
5. Save the serialization file on your computer in an easily 

remembered place (For Example: your desktop) 
6. Attach the serialization file to an email and send to: 

Activation@PhotoLynx.com  
Note: Please include your name and business as part of your 

email 

 How to Load an Activation File:  

1. You will receive a .cyp file from the PhotoLynx® activation 
clerk. Save this file on your computer in an easily 
remembered place (For Example: your desktop) 

2. If an Activation menu doesn’t automatically pop up, go to the Help>About menu and click on the 
Activation button 

3. Select:  File>Load Activation File 
4. Browse out for the .cyp file you have saved to your computer 
5. Exit software and then run again to confirm the activation 

mailto:Activation@PhotoLynx.com?subject=Serialization%20File
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Overview 

ProServices© is a simple program for creating service items (like Mugbooks and ID cards) that may be 
repeated several times on a page. 
 
A service that is set up in ProServices© may be printed to an image file, any installed Windows printer or 
set up as a unit to be rendered out as a package through RipLynx!©, depending on your needs.  
 
There are many common services included when ProServices© is installed. PhotoLynx® offers a library of 
graphics, templates and services.  
 
ProServices© uses the Service Setup to determine the paper size, number of times to repeat the 
template on a page, and which template(s) to use. Custom services can be created easily, either by 
starting from a blank service or selecting a similar setup and modifying it to your needs.  
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The File Menu: Service Setup 

The Service Setup option is where all services are modified. The current service is displayed as the 

Service Name on top of the Service Setup screen. The down arrow to the right of the Service Name 

displays a drop-down box containing a list of services. 

Note: “Service Setups” is another term for service page layouts. The margins, sort, header & footer along 

with templates on a service page are called the “setup”. Service setups are stored in a folder identified as 

the Setups Folder under Preferences.  
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Page Tab 

The Page tab is where we choose to print to the default printer or to an image file. The default printer, 

margins, orientation and the calculated “cell size” are highlighted on the Service Setup tabs. 

 

 When the Print to Image option is selected 

both the image type and page size are 

specified. Image types include Bitmap (.BMP), 

Tagged Image File Format (.TIFF), JPEG (.JPG) 

and Targa (.TGA).  

 If Print to Image is not checked, your windows 

default printer will be displayed. To switch 

printers, go to File>Printer Setup and choose 

your desired printer. 

 Press the Page Graphics button to select an 

Overlay and/or an Underlay for your service. 

 The Cell Setup section of the Page tab sets the 

number of vertical (columns) and horizontal 

(rows) cells on the service. The greater the 

number of cells, the smaller each individual cell 

will become. The cell size is calculated from the 

page size, the margins and the number of cells. 

 The Service Layout section of the Page tab contains the print order of the cells, which can be 

from left to right (the default) or from top to bottom. 

 Stack Sort allows you to print your services through the stack of paper for stack cutting. This 

works wonders for ID Cards. To cut the stack: 

o Place Stack 1 on Stack 2 

o Place Stack 2 on Stack 3 

o Place Stack 3 on Stack 4 

o Place Stack 4 on Stack 5 

o Place Stack 5 on Stack 6 

 

Note: The dimensions of the image file are 

identical to the printed output. File sizes will 

vary depending on specified size of the output 

image file and the dots per inch (DPI). An 8.5 x 

11 TIFF image file at 300 DPI will be 

approximately a 24MB file. 

  



 

 

  PhotoLynx® ProServices©    7 

Margins Tab 

All margins are calculated in inches. When printing to a printer, as opposed to an image file, the printer’s 

default margins display in blue next to the top, bottom, and left and right margins. ProServices© reads 

the default printer margins and from the currently selected printer and displays them as a reference. If 

the margins set for a service are not greater than the printer margins, part of the service will be cut off 

when printing. 

When calculating the total vertical print area of a service, the Header and Footer margins are added to 

the top and bottom margins. In other words, a top margin of 0.5 inches and a header margin of 0.3 

inches will cause the top of the first cell to start 0.8 inches from the top of the page. 

The Cell Spacing defines the white space between cells. To vertically separate each template by 0.25 

inches, the vertical cell spacing would be set to 0.25 inches.  
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Header/Footer Tab 

Headers and footers can be included on services by modifying the contents of the Header/Footer tab. 

 To include a header on a service, select a header from the pick list right above the Edit Header 

button. 

 

 To create a new header or footer, type the new name and click on the Edit button. 

 

 The Edit Header button displays the edit screen. 

 

 The Note section on this screen describes the basic header and footer functions. 
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Sheet Tab 

The Sheet Tab contains the template(s) found in the service, the number of copies of each template and 

the sort for the service.  

 Next to Template #1 is the name of the template inserted into each cell of the current service. 

By clicking on the down-arrow to the right of the template name a list of all templates is 

displayed for selection. The Template #2 and Template #3 options are used when creating 

service strips. 

 

 Copies indicate how many times each subject will be repeated on a service. In other words, to 

print a sheet of labels of student pictures with each student repeated six times, Copies should be 

set to six (6). 

 

 The Sort feature filters and sorts the students. Sort options are edited on the Sort Configurations 

screen by clicking on the Edit Sort button. 
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Sort Options 

There can be any number of predefined sorts. Each sort can have up to three filter statements for 

defining a group of students. 

 The Use box to the left of the filter statements turns each filter condition on and off. The only 

filter statements used are those that have the Use box checked. 

 The Operator column contains the “logical operator” for each filter condition. The down-arrow 

next to each operator displays a list of valid operators. The operators are: 

o Equal (=) 

o Not Equal (< >) 

o Greater Than (>) 

o Greater Than or Equal (>=) 

o Less Than (<) 

o Less Than or Equal (<=) 

o Like (compare string contents) 

 All operators are self-explanatory except Like. 

The Like operator supports “wild cards” for 

filtering. The asterisk character means “any 

characters”. Valid Like conditions include ‘*N’ 

(all students whose field ENDS in ‘N’), or ‘N*’ 

(all students whose field begins with ‘N’) or 

*N* (all students whose field contains the 

letter ‘N’). 

 The Group By option beneath the three filter 

statements sorts the students in ascending 

order by any field. The Start New Page check 

box tells the system to start a new printed 

page each time the field in the Group By box 

changes.  

 The Order By option sorts the students by a second field.  

 The Preview button in the lower-left hand corner of the Sort Configurations screen displays a list 

of the selected students. 

 The New button creates a new sort and the Save button saves the current sort. When creating a 

new sort, type the name of the sort in the Sort area at the top of the screen and then select the 

criteria desired. To complete the process of adding a new sort, click on the Save button. 

 A list of all defined sorts can be displayed by clicking on the down-arrow next to the Sort prompt 

on the top of the window. 

Notes: In addition to the Group By and Order By sort fields, all sorts also include both the last name 

and first name as a third and fourth sort fields respectively. 
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Process Tab 
The Process tab is where you would specify if your 

service will be for group pictures or if you are 

creating CD labels to be used in printing CD’s in PT 

Burner.  

If creating a service which will be using group 

images, be sure to accurately set up your group 

images in ImageMatch© and then check off the box 

under the Process tab in ProServices© labeled 

Process Group Images for Printing. 

If you are using the PT Burner and would like to set 

up your template to be a CD label, select CD Label 

under Service Type.  

Service Setup File Menu 
Use the File menu on the Service Setup screen to create new services, save the current service and 

change printer settings. 

The Save As option is used to create new services by editing an existing service with a similar layout then 

saving it under a different name. The default save file name is the name of the current service.  
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Creating Services: The Basic Steps 

Here are the recommended steps for creating new services in ProServices©: 

1. Sketch the service’s layout by hand including the desired template positioning, the page size and 

the margins. This step will help ensure the templates will be the correct size for the service page 

you want. 

2. Create template(s) in the Template Builder to match your service page’s layout. 

3. Create a new service by opening an existing service similar to the one being created. 

4. Modify the five Service Setup tabs and save the new service under a new name. 

The Template Builder 
To change the size of the template, select Template Size from the Edit menu. There are 3 template size 

options: ID Card, Full Page and Custom. If custom is selected, windows will pop up for entering the 

height and width of the template in inches.  

Most functions of the Template Builder can be accessed from both the menus and the buttons, allowing 

you to work in the way that is most comfortable for you. 
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Template Builder: Objects 

A template is made up of objects, which can be graphics, images, text or barcodes. 

The Object List, to the left of the editing buttons above the template, is a drop down list of all objects in 

the current template. You can select an object for editing by choosing it from the Object List or by 

clicking on the object. Clicking on a handle and dragging the mouse can resize objects. Objects are 

moved by clicking on it and dragging it to the new location. Alternately, pressing the Shift key with the 

arrow keys on your keyboard will move the object and pressing the Ctrl and arrow keys will resize the 

object. All the functions of the editing buttons are also found on the editing menu. 

When an object is selected, a floating tool window pops up. The floating tool window pops up. The 

floating tool window has different options for each type. Some adjustments that can be applied to an 

object from the floating tool window are: 

 Select the image file to use for an image object 

 Entering the static text and/or data fields to be used for text objects 

 Rotation of text or image objects 

 Formatting fonts for text objects and barcode fonts 
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Template Builder: Tools 

The Color Selection Panel at the top allows you to select the color for the Pen or Fill colors 

below. The color selected is shown below the spectrum with its associated RGB value.  

The Pen(foreground) and Fill (background) colors can be selected by clicking on their 

respective boxes. This will bring up the Windows color spectrum for color selection. 

To fill a graphic object with the selected fill color, click in the Fill checkbox.  

The Transparency option allows you to remove a selected color from the template. This is 

used when you want the subject’s image to come through a spot in a graphic. The default 

transparent color is magenta (255-0-255 on the RGB scale), but the ink dropper is used to 

select any color on the template as the transparent color to work with in your template 

colors. 

The Tolerance slider bar allows you to take out a little or a lot of the color until the color is 

removed but image quality is not affected. 

 

  

Note:  ProServices© is unable to read transparent PNG’s. To print 

something using a transparent PNG’s, you must render your service 

through RipLynx!© 
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Reset Template Size 

Templates can be easily resized on the Template Builder main screen using the right mouse button. 

Resetting a template’s size returns it to the original size as defined when the template was created in 

the Template Builder.  

The recommended procedure is to create templates in the exact size needed for the service. Templates 

can be easily scaled maintaining proportions, but to achieve the best print quality possible we 

recommend templates be created exactly to print specifications.  

 

The Print Menu:  

Print Preview 

Print Preview merges students into the selected template and displays the first page. 

  



 

 

  PhotoLynx® ProServices©    16 

Enable Codabar Check Digit 

The Enable Codabar Check Digit option corrects barcodes for library systems using the Codabar barcode 

symbology (this is used in Library of Congress Systems only.) 

 

Print 

The Print option prints the services for all students or by a range of pages. 

Depending on your Service Setup, your services will either print straight to your printer you have 

selected or as an image.  
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The Help Menu 

 

 

 

Activation 

Selecting this option will bring up the activation 

window. In order for ProServices© to be activated you must have ImageMatch© activated as well. 

ImageMatch© is required for running ProServices© due to the critical nature of aligning student data to 

captured image files.  Please see To Activate for further information.  

 

 

 

About ProServices© 

About ProServices© contains the latest software version and system information  
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Green Screen Proofs 

Since many studios/labs are offering quite a number of backgrounds to select from, it is recommended 

that you create a graphic that contains ALL desired backgrounds that you want to give as an option on 

one sheet, as well as your pricing/ordering information. This makes creating the template in 

ProServices© a breeze since you will add only one external graphic as opposed to several. This will help 

the rendering process go faster as well.  

1. Create a new service, making sure the page size, margins and headers/footers are set up 

accurately 

2. When creating a new template, click Edit>Add Object>Image 

3. Name the object something logical, such as “background”, and click OK 

4. On the Image Tools box that pops up, double click in the white space next to Filename 

5. Browse to find the graphic you build that contains all the pricing, order info and background and 

click Open 

6. Using the white square “handles” on the corner of the graphic, stretch it to fit over the entire 

template area 

7. Go to Edit>Add Object>Image and name this object “Pose 1” and click OK 

8. On the Images Tools box, double click the whitespace and this time select the .8crop.bmp file 

and click Open. This will be your “placeholder” image 

9. Just below the Filename area on the Image 

Tools box, click on the data field drop-

down and select Image Name 

10. Now drag the sample image and 

stretch it to fit over the first sample 

background that is on your proof 

sheet graphic. You want to stretch it 

so that it fits exactly over the 

background, covering it completely 

11. To use the crop set in ImageMatch©, 

check off Auto Crop 

12. Go to Edit>Duplicate Object and name 

this one “Pose 2”. Click OK. The copy 

will be directly over the first one 

13. Click on the copied image and drag it 

to fit over the second sample 

background on your proof sheet, 

again covering it completely 

14. Repeat these steps for as many 

backgrounds that you wish to place  
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How to Create 3 Dimensional Proofs 

One thing many people like to offer is 3D Green Screen images. You can create a proof sheet showing 

these options. 

1. Open your Green Screen Proof you previously created 

2. Edit your Template 

3. Go to Edit>Add Object>Image 

4. Name this “TopLayer 1” and click OK 

5. On the Images Tools box double click the white 

space and select the transparent PNG image that 

you created as the top layer portion of your 3D 

image. This image MUST be a transparent PNG type 

image, non-interlaced 

6. Click Open. The image will not display properly in 

ProServices© - the transparent areas will actually 

show as white. This is fine and will preview fine in 

the PUD and render out nicely.  

7. Now drag this layer and stretch it to fit over the 

first sample background/sample images that have 

already been layered together. This will create a 

third layer in that same spot. You want to stretch it 

so that it fits exactly over the sample student 

image, covering it completely. 

8. Duplicate this object and place over every image spot 

on your proof, and render through RipLynx!© as usual. 
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Multi-Pose Proof Sheets  

ImageMatch© Setup 

Before you can set up a multi-pose proof sheet in 

ProServices©, you must first have your proof sheet 

conversion set in ImageMatch©: 

1. Go to Data>Proof Sheets 

2. Select Enable Proof Sheet Conversion  

3. Under Fields to Match click Select None  

4. Select a field from the Fields to Match box 

that will uniquely identify each subject, such 

as Student ID, Record Number or Ticket Code 

5. On the right side  

Creating Your Service 

Once you have enabled your proof sheet conversion, you are now ready to build your proof sheet: 

1. Open ProServices© 

2. Select pl_proof.srv. This is a good guildeline for a simple proof sheet template 

3. Edit the pl_proof.tem template. Take a look at the fields used for the images 

4. Modify and rename the template/service to fit your needs 

5. Add your proof sheet service to your PUD in ImageMatch© 

6. In the PRM configuration, create a proof package with the only unit being the proof sheet 

7. Map the Map # something unique, such as “P” for Proof 
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Add the Proof Package to Students 

Now that your proof is set up as a package in your PRM, you are ready to assign this package to all 

subjects: 

1. In ImageMatch© go to Data>Replace Data 

2. Leave the first field as Code and the text 

to the right empty (if you have data in the 

Code field, select a different field that 

contains no data) 

3. In the second field, scroll down and select 

Packages 

4. Type P-1 in the text field to the right 

(replace “P” with your proof package’s 

Map # you created in your PRM if you did 

not set it as “P”) 

5. In the bottom list of selections, make sure 

you select the first item in the list. This will 

place a “P-1” in the packages field for every data record 

Printing Proof Sheets 

Now that your proof sheet packages are assigned to all subjects, you are ready to send to print: 

1. Go to Data>Tagging>Tag Pose 

2. Select Pose 1 as the pose to tag. This 

tags the first image for each student 

3. Click on Print>Send Packages to 

RipLynx!© 

4. Click on File>Select Tagged Images (or 

Ctrl-T) 

5. Click on Print 

Note: Be sure you use the same PUD file 

for both ImageMatch© and RipLynx!©  
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Adding Your Image Name to your Multi-Pose Proof Sheet  

After you have set up your proof sheet conversion in ImageMatch© and are now building your service in 

ProServices©, you have the ability to add the image name for the specific pose on your service. 

1. Create a text object by going to Edit>Add 

Object>Text and name your object, such 

as “Pose 1” 

2. In the Static Text type %Pose#.Field% 

3. For the # section – type in your pose 

number. For the Field section, type in the 

field name in which you set up in your 

Proof Sheet Conversion 

For Example: %Pose1.Custom7% 

4. Continue through these steps until you have text for all of your poses 

 

 

 

Dynamically Change Graphics 
You can set up ProServices© to automatically change graphics within a template based off data in a 

subject’s record. To do this: 

1. Save your graphics into a folder on your computer or network 

2. Add an image layer in your template. In the Image Tools box, select the data field that will be 

used to dynamically place your image onto the service 

For Example: Custom8 

6. In ImageMatch©, enter the path of the graphic for the individual into the data field select in the 

template builder 

For Example: In Custom8, type the full image path – C:\Program Files 

(x86)\Photolynx\ProServices\Graphics\1.jpg 

7. When you print your template, your graphic will change per individual based on their data 

 


