
 

 

 

PhotoLynx® ProComposites© 

User’s Manual 
 

ProComposites© is designed to easily create and print volume composites.  

ProComposites© also has the ability to efficiently create star or individualized composites. 

 

 

 

 

PhotoLynx® Mission Statement 
PhotoLynx®, Inc. strives to keep abreast of the latest hardware and software technology while continuing 

to support existing standards. PhotoLynx® places the highest value on supporting and serving our clients. 

PhotoLynx® seeks to align itself with businesses providing hardware, software and services that will 

benefit our clients in the photographic industry.  
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Getting Started  

Before installation, your computer must meet the following requirements: 

System Requirements 
Minimum: 

 Intel Celeron or AMD Duron processor @ 1.5 GHz 

 Microsoft Windows 7 

 1GB of RAM (for Green Screen V.2, a MIN of 2GB is needed) 

 4 GB of available hard-disk space 

 Color monitor with 8 million (16-bit) or greater video card 

 Monitor resolution of 1024×768 or greater 

 CD-ROM drive 
 

Recommended: 

 Intel Pentium 4 or AMD Athlon XP processor @ 3.0 + GHz; Duo or Quad core for faster rendering 

 Microsoft Windows 7, Windows 8 

 32 or 64 bit 

 4-8 GB recommended for GS V.2 

 160 GB of available hard-disk space 

 Color monitor with 16 million (32-bit) or greater video card w/64 MB of RAM 

 Monitor resolution of 1024×768 or greater 

 CD-R / CD-RW, DVD-R drive 

 Fast Connection to the Internet (including e-mail) 
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Instructions for Installing/Activating ProServices© Software 

 You should have received an email from either the PhotoLynx® Technical Support office or your lab with 

the base install of ProComposites©, as well as 2 upgrade links.  

To Install: 

1. Download all three downloaders that were emailed to you 

2. Run each installer in order they were sent to you, making sure to right click on the installer and 

choose Run as Administrator 

3. Follow the install prompts 

4. Once finished installing all three links, right-click on your ProComposites© icon on your desktop 

5. Select Properties 

6. Under your Compatibility tab, check off Run this 

program as an administrator 

7. Click Apply then OK  

To Activate: 

ProComposites© will be activated along with your ImageMatch© 

software. To activate your ImageMatch© software, we first 

need to receive a serialization file from you. Once received, we 

will email back an activation file to load into the software. To do 

this: 

How to Submit Serialization Files:  

1. Run ImageMatch©  
2. If an Activation menu doesn’t automatically pop up, go to the Help>About menu and click on the 

Activation button 
3. Completely fill out the customer information  
4. Select:  File menu>Create Serialization File 
5. Save the serialization file on your computer in an easily 

remembered place (For Example: your desktop) 
6. Attach the serialization file to an email and send to: 

Activation@PhotoLynx.com  
Note: Please include your name and business as part of your 

email 

 How to Load an Activation File:  

1. You will receive a .cyp file from the PhotoLynx® activation 
clerk. Save this file on your computer in an easily 
remembered place (For Example: your desktop) 

2. If an Activation menu doesn’t automatically pop up, go to the Help>About menu and click on the 
Activation button 

3. Select:  File>Load Activation File 
4. Browse out for the .cyp file you have saved to your computer 
5. Exit software and then run again to confirm the activation 

mailto:Activation@PhotoLynx.com?subject=Serialization%20File
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Overview 

ProComposites© generates composites based on the number of students and staff for each composite 

using the images and data that are linked in ImageMatch©. 

 

ProComposites© creates each composite by calculating the optimal number of rows and columns to 

maximize the image size for all students. This process enormously simplifies the production by 

generating composites while taking into account all composite settings such as composite size, 

orientation, margins, white space, title block area and image crop size.  
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Grouping in ProComposites© 

When loading a job into ProComposites© for the first time, it will be necessary to set the Grouping field 

and the Staff Criteria. 

1. Open ProComposites© 

2. Select a previously saved job (or current job if 

opening through ImageMatch©) 

3. Select the field used to group the students 

It is most common to group students by the teacher 

field, but any field can be used to group students. There 

is no limit to the number of students that can be placed on a single composite. 

Loading the Staff Criteria 
Staff Definitions tell ProComposites© what 

field is used to define who is staff, what 

levels of staff are available and how to 

combine staff onto the composites. 

Each time a job is loaded into 

ProComposites© for the first time, the 

system will warn the Staff Criteria 

Definitions have not been defined. Next, 

ProComposites© will display the screen for 

defining the Staff Criteria Definitions.  

To load staff defaults, select the Load from 

System Default File option from the File 

menu. These settings may be customized 

for various school situations by changing 

the titles. When Combine to All is checked, 

every staff member with that value 

assigned to them will be included on all 

composites for that job.  
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Composite Groups 

The Group Name list found at the top of the 

Composite Setup screen is created automatically 

using the Group Data field.  For example, if the 

Teacher field was the selected Data Field, then 

the Group Name list contains each teacher’s 

name for the current job. Each teacher in the 

Group Name list corresponds to a class 

composite. The total number of teachers in the 

Group Name list is equivalent to the number of 

individual composites in a particular job.  

Composite Setup Tabs 
The main Composite Setup window has nine (9) tabs. Each tab is labeled to simply describe the 

configuration options within the specified tab. 

Until a tab has sufficient information to generate a composite, a red ‘X’ will appear next to the tab 

name. The Preview, Print and Auto Print buttons will NOT work until all red X’s are gone. Once the 

settings for a tab have sufficient information to generate a composite, the red ‘X’ disappears from the 

tab.  
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Page Tab 
The Page tab is where the composite size, 

orientation and margins are entered. 

The Page Size defines the exact size of the 

composite. The page size may be selected from one 

of the preset sizes or select the Custom option to 

set a new size. 

The Orientation area allows for portrait or 

landscape layout of the composite.  

The Margins define the distance images will start 

from the edge of the composite.  

Sort Tab 

The Sort tab defines the order in which students are placed on the composite. The Conditions area is 

used to limit the students based on a data field using logic like: “Select all students who have ‘STAFF’ in 

the teacher field OR have a value greater than zero in their criteria field”. 

Order By sorts how the students are to be displayed on the composite. The Asc and Dec check boxes sort 

the displayed students in ascending and descending orders respectively. The last name and first name 

fields are always added to the Order By sort field making all sorts a three-field sort. For example, if Order 

By is set to Home Room, the sort fields are Home Room + Last Name + First Name. 

Remove Staff removes all records with a non-zero staff criteria field. 

The Clear button resets all the Sort Tab settings to the defaults.  
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Names Tab 

The Names tab controls the display of student names on a composite. 

The % of White Space for Names option determines the white space available for names beneath the 

images. Common white space percentages range from 10% to 15%. 

The Hide Names option removes all names from the composite. If including names on a composite, the 1 

Line and 2 Lines options are used to select single line or double line display. Putting the combined first 

and last name on a single line would be a common example of when the 1 Line option would be used.  

The centering buttons for fonts are used to left-justify, center or right-justify a student’s name beneath 

the image. When displaying only a single line using the 1 Line option, the top-justify, middle and bottom-

justify options become available for the fine-tuning the vertical positioning of the single line of student 

information.  

The Font setting selects a TTF font from the Windows fonts. When Scale font size to fit, the font size 

selected is the maximum font size for a student name. In other words, a student with a short name line 

“Lisa Smith” might use the maximum font size of 26, but a student on the same composite with a name 

of “Robert Mittricker” might not fit beneath the image. The system will automatically reduce the font 

size for a name until the entire name fits beneath the image.  
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Staff Tab 

The Staff tab contains a list of all staff on the current composite based on the criteria values assigned to 

the data records in ImageMatch©. Each staff member is given a non-zero criteria value from 

ImageMatch©. The Staff Criteria Definitions in ProComposites© associates each staff level with a position 

on composites.  

The Staff tab for any particular group lists all Combine to All staff as well as the teachers and assistants 

for the current group. There are 6 spaces for staff on a composite so they any extra staff members, like 

teacher assistants, can be included on the composite for their class.  

Combine to all Composites places all staff with the specified criteria value on all composites for a job.  

First position is the position before all students. All staff assigned to first position will be placed before 

the students, alphabetically by criteria value.   

Last position is the position after all students. All staff assigned to last position will be placed following 

the students, alphabetically by criteria value.   

In some cases, teachers and assistants are included on more than one composite, but not included on all 

composites like a superintendent. The pull-down menu next to each box in the Staff List will add or 

change a staff member on the current composite. Clicking on the arrow will display a list of all staff for 

the entire job to choose from. 
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Title Block Tab 

The Title Block tab selects the title block 

template for the current composite, and the 

placement and sizing for the title block. To 

use a title block on a composite, click Enabled 

next to your title block selection. 

To select a template to use for your title 

block, double click in the file name line and 

browse out for your previously made 

template. 

To edit the current title block, or to create a 

new title block, click the Edit button. This will 

open the PhotoLynx® Template Builder. Title 

blocks can be any combination of text and 

graphics. 

The title block is positioned on the composite 

by selecting the alignment from the Alignment 

grid. 

Select the number of cells, or inches, horizontal and vertical to select the title block. The cell size is 

based on the number of images on a composite with each cell being the size of one image. 

The title block is centered in the space defined by the Alignment and Size areas of the Title Block tab.  
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Images Tab 

The Images tab defines image spacing and the 

mask of frame for each student image.  

To use a mask or frame around the images on a 

composite, check the Use Mask or Frame 

checkbox. Double click in the file name box to 

select the mask or frame to be used. 

When using a mask, clicking on Edit allows for 

modification of the edge fade and positioning of 

the mask. Using the mask option, masks can be 

elliptical, rectangular or rounded rectangular. 

A frame is a graphic that is placed on top of each 

image with a transparent center where the image 

shows through.  

The White Space indicates the amount of space to 

be placed between images. The vertical white space 

is added to the percentage of white space used by the Names tab for positioning text beneath images.  
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Background Tab 
The Background tab defines the background 

image file (such as a logo) or defines it to be 

solid or gradient colors. 

The entire Windows color spectrum is 

available for Solid and Gradient 

backgrounds. A large variety of gradient 

styles are available from the gradient drop-

down menu. 

To use an image file as the background, click 

the Use Background Image checkbox, and 

select the image file to be used by double 

clicking in the file name box.  

 

 

Preferences Tab 

The Preferences tab defines the default folders for support files and for printing. 

To change where ProComposites© looks for your preferred folders, double click in the white box 

underneath the folder name and browse out to find the correct folder.  
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Individuals Tab 

Individual composites allow for the personalization of composites for each student in a class. Each 

subject is rotated into a specified position and shown at a larger size to highlight their image. 

 To use the Individual feature, click the Enable individual feature composites checkbox 

 Include Individual in group composite places each student in the highlighted position as well as 

in the body of the composite 

 Include Staff allows the individual feature to personalize composites for staff members as well 

as students 

 Only Print One Individual Composite enables a choice of which person to highlight instead of 

rotating through the entire group. This can be used to highlight the teacher or to make 

individual composites only for subjects who ordered a composite 

 The Alignment area selects where the individual will be placed on the composite from a grid 

 The Size area defines the number of cells horizontal and vertical to make the individual. The cell 

size is based on the number of images on a composite with each cell being the size of one image 

 The Text Size area defines the font size and scaling to use for the individual. The font type is 

chosen on the Names tab 
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Saving & Loading Default Composite Settings 

Once you have your composite set up to where you like, you can quickly set up all the settings for the 

other groups, as well as other composites later. The first two options on the main File menu on the 

Composite Setup screen allow the user to Save and Load the default settings respectively. These options 

contain the settings for all nine tabs. 

1. First, you must Save your composite settings under the File menu, and name this file something 

you can remember (For Example: Ramona Elementary Composite) 

2. To quickly generate a composite, load the default composite settings from the File menu and 

click on the Generate button 

3. Be sure to adjust the nine tab settings until the composites have the look and feel you want 

Note: The default composite settings contain default information for ALL nine setup tabs, but do not 

contain the staff definition settings. 

Print Settings 

When outputting composites to a printer, select the Printer from the printer list at the top of the print 

setting window and uncheck the Print to Image option. 

The DPI (dots per inch) setting is used when printing composites to image files. When outputting 

composites to image files, the Image Number is added to the current “group name” to create the name 

of the composite image file.  

Composites may be saved as JPG, TIFF, TARGA, or BMP files. To name the images individually in a 

different name format, select the Prompt for filename when saving. This option will bring up a file name 

save dialog for each composite generated. 

Composite image files are saved in the Destination Folder. Clicking in Create Subfolder Based on will 

create a folder under the Destination Folder using either the Job Name or the Group Name and place all 

composites for the job or group into the subfolder.  
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Previewing & Printing Composites 

After all settings have been defined, and there are no red X’s visible on any of the tabs, it’s time to 

generate a composite. Click the Preview button in the lower left corner of the Composite Setup window 

and let it run its course. A window will appear with the newly generated composite. 

To Print: 

1. Go to File>Print Settings 

2. Define a printer, or print to image 

and save the file to your computer 

for printing at a later time 

3. Click Exit 

4. Go to File>Print 

The generation window will disappear 

leaving the Composite Setup window. Click 

Exit in the lower right and decide whether or 

not to save the composite.  

Auto Printing Composites 
Auto Print will use the settings in the default file that is selected for all composites in a job, and send the 

finished composite to the image print folder or to the selected printer. Please note that the Auto Load 

Composite Settings for New Composites feature will NOT overwrite any settings that have been manually 

changed on the next composites, unless you request it to. If each composite requires customization of 

the staff, title bloc or other settings, Auto Print cannot be used to generate the composites. To Auto 

Print all composites for a job: 

1. First make the composite settings for one classroom, and Preview to make sure everything is 

correct 

2. Go to File>Save Composite Settings to save the composite setup as a default setup 

3. Go to File>Load Composite Settings 

4. Choose the default you would like to use for this job 

5. When it asks Apply Settings to All Composites select Yes 

6. Go to Composite, select Auto Save Composite 

7. Click on Auto Print at the bottom of the Composite Setup window 
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Printing Composites Based on Packages 

To print out your composites based off of specific package information set in ImageMatch©: 

1. Go to File>Print Settings 

2. Select the Package Printing tab. The 

Print Settings window will be displayed 

3. Check the […] button to select your 

package program (.prm) file 

4. Choose your Packages field 

5. For Print if Record Contains, select 

Package 

6. Choose the package that includes the 

composite 

7. Click Close 

8. Go to File>Print>Print Package 

Composites 

 

Print Composites Based on a Unit 

To print out your composite based off a specific unit set in your package information in ImageMatch©: 

1. Open ImageMatch© 

2. Go to File>Preferences 

3. Select the Packages tab 

4. In the Program section, click the Config 

button 

5. Add a custom unit called Composite to 

your package(s) 

6. Save your new program 

7. Open ProComposites© 

8. Go to File>Preferences 

9. Select the Package Printing tab 

10. Click the […] button to select your 

package program (.prm) file 

11. Choose your Packages field 

12. For Print if Record Contains, select Unit 

13. Choose the composite unit you created 

14. Click Close 

15. Go to File>Print>Print Package Composites 


